XMind 3.2.1 バージョンアップトラブル

XMindを3.2.1にバージョンアップしたときのトラブルと解決方法を記録しておきます。

環境

私の職場PCの環境は以下のとおり。

  • XMind 3.2.1 – Windows Installer 版
  • Windows7 Professional (x68)
  • JAVA_HOMEで指定されるデフォルトJava VMが JDK 1.4 orz
  • Java6はインストール済み

今までは -vm オプションで Java6 の javaw.exe を指定していた。
3.2.1 にバージョンアップしたところ後述のエラーで起動せず。

解決法

C:\Program Files\XMind\xmind.ini を編集して以下を -vmargs の前に追加。

-vm
C:\Program Files\Java\jre6\bin\client\jvm.dll

※パス等は適宜修正願います

記録

まずは素の状態では以下のとおり。

Version: 1.5 or greater is required

Version 1.4.1_05 of the JVM is not suitable for this prodict. Version: 1.5 or greater is required.

VM が古いと怒られる。

次に C:\Program Files\XMind\xmind.ini を編集して以下を -vmargs の前に追加。

-vm
C:\Program Files\Java\jre6\bin\javaw.exe

Could not find the main class

Could not find the main class:
Files\XMind\\plugins/org.eclipse.equinox.launcher_1.0.201. R35x_v20090715.jar -os win32 -ws win32 -arch x86 -showsplash -launcher C:\Program. Program will exit.

どうやら Program Files の間のスペースを区切りと誤解しているようだ。

ダブルクォーテーションでくくってみた。

-vm
“C:\Program Files\Java\jre6\bin\javaw.exe”

No Java virtual machine

A Java Runtime Environment (JRE) or Java Development Kit (JD) must be available in order to run Xmind. No Java virtual machine was found after searching the following locations:
“C:\Program Files\Java\jre6\bin\javaw.exe”

う~ん、どうもダブルクォーテーション込みで実行ファイル名と誤解しているようでうまく実行できないらしい。

ググった。

“Portable 版” を使えとの英語の書き込みもあり試してみる。
こいつは全部入りなので XMind に必要な VM も備えている。
動いた!
なぜ?

xmind.ini を見ると -vm オプションで jvm.dll を指定している。

ということで、xmind.ini で jvm.dll を使うように修正した。

動いたよ!!! \(^_^)/
でも正直なところなぜこれで動くのか分からないし、javaw.exe でも本当は動くのかもしれない。

とにかくあまり多くはないであろう、私と同じような環境の方の参考になれば幸いですw

XMind 3.2.1 バージョンアップトラブル” へのコメントが 2 点あります

  1. ピンバック: Androidアプリ開発環境を 42分で構築する(1時間切りに挑戦) | android manifest configChanges

  2. ピンバック: Eclipse起動時エラーの傾向と対策 | android manifest configChanges

コメントを残す

メールアドレスが公開されることはありません。